21 de Noviembre, 2010

Problemas con Empathy en Fedora 14

Antes de que instalara Fedora 14 en mi nuevo equipo, ya me había pasado a Empathy, dejando de lado a Pidgin depués de muchos años.

No es en realidad un problema de Pidgin sino una cuestión de funcionalidades de Empathy gracias a framework Telepathy (que aporta el soporte a los distintos protocolos), y que está mucho mejor integrado con el escritorio Gnome.

Es cierto que el interfaz de Empathy está algo verde, si lo comparamos con el de Pidgin sobretodo, pero me aporta ventajas como el soporte VoIP con SIP ¡que funciona!

Pero la versión 2.32.0.1 tiene unos fallos realmente molestos, sobretodo para mis casos de uso, y además son problemas que puede que no se corrijan en Feadora 14.

Son cosas me afectan a mi (igual otros perfiles de usuario ni se enteran):

  • Cannot edit local Alias for accounts in Empathy: es un problema realmente confuso, y que por ahora no me afecta demasiado porque he puesto un alias y parece que lo respeta :P.
  • Contact list pane start with zero size: no es terrible, pero aunque ha atraído algo de atención en upstream, no ha sido corregido (no parece trivial).
  • Typing a Long Message Resizes the Application Window: este es probablemente el más incómodo de todos, que hace la aplicación casi no se pueda usar en charlas en grupo e IRC (hay un vídeo que muestra el problema).
  • Disabling an account while connected doesn't update the rooster: este fallos además puede acabar con la aplicación cerrada de mala manera (con core incluido).

    Es un error del componente Folks, que casualmente está corregido, pero no se puede actualizar a la versión de la corrección porque necesita actualizaciones en la infraestructura de Fedora 14 (concretamente gobject-introspection), y el desktop team no puede permitirse actualizar.

    He hecho backport de la corrección (y lo he mandado al encargado del paquete), pero ni siquiera puedo reconstruir el paquete para tener mi versión arreglada debido a una actualización posterior del compilador de Vala (!).

En definitiva, se alinean los planetas para que la situación sea la peor posible :). Por una parte los fallos se han corregido en versiones posteriores, y no hay recursos para hacer backport de esos parches, y por otra algunos componentes que integran la aplicación han sido actualizados sin mucho acierto (el paquete Folks, por ejemplo, no se puede reconstruir).

Tengo que reconocer que Fedora 14 me ha decepcionado un poco en lo que respecta a Empathy. No son problemas fatales, pero sí dan una imagen de mal acabado cuando te topas con estos fallos en la aplicación de mensajería que se instala por defecto (imagina que pruebas Fedora por primera vez y te encuentras estas pegas).

Como próximamente voy a dejar de usar VoIP con SIP, es más que probable que vuelva a Pidgin hasta que Empathy esté más maduro. Sin duda es el futuro, pero el ritmo de desarollo complica demasiado el soporte en cualquier distribución y pueden pasar estas cosas :(.

Actualización: igual podría haberlo dicho más claro, pero por si acaso: la mala release es de Gnome; no obstante el distribuidor tiene ciertas responsabilidades, y Fedora implementa su propia QA para ello. No solo es empaquetar/integrar aplicaciones.

Anotación por Juan J. Martínez, clasificada en: fedora, gnome.

Los comentarios están cerrados: los comentarios se cierran automáticamente una vez pasados 30 días. Si quieres comentar algo acerca de la anotación, puedes hacerlo por e-mail.

Algunas anotaciones relacionadas: